News» Announcements

ALERT - Security hole in Zenphoto 1.4.1.4

Zenphoto 1.4.2 BETA

PHP4 no longer supported with Zenphoto 1.4.1

Zenphoto requirements

Issue with 1.4.1 installs

Zenphoto now Tweets

Announcing Zenphoto v1.4.1 Beta

Paid support now available

Zenphoto on Twitter

Security reports that do not make sense