News

PHP4 no longer supported with Zenphoto 1.4.1

    We have intended to drop support for ancient versions of PHP and MySQL--see http://www.zenphoto.org/news/zenphoto-requirements. It seems this has come sooner than anticipated for PHP version 4. The Zenphoto 1.4.1 release will generate PHP errors in several critical functions due to parameter changes we have made.

    We have decided that the effort to change these references so that PHP 4 does not fault is both undesirable for the future of Zenphoto and potentially too destabilizing to the current release.

    For this reason Zenphoto 1.4.1 and onward now requries PHP 5 or higher. We regret this post-facto notice. We did not notice this as we are working on PHP 5.2+ (as noted on the Zenphoto requirements page as well).

    If your site is running on PHP4 you will need to change to PHP 5 or newer before you will be able to install the current release of Zenphoto.

    For questions and comments please use the forum or discuss on the social networks.