zenphoto forums » General Zenphoto Discussion

Error using logout in Admin

(7 posts)
  1. elrol

    Member
    Joined: Jan '09
    Posts: 46

    I am using : version 1.4.1.6 [8326](fresh install) and when I click log out in the admin area, I am taken to /zp-core/admin.php?logout=0 and get the following php message :Catchable fatal error: Object of class __PHP_Incomplete_Class could not be converted to string in {MYDOMAIN|/zp-core/lib-auth.php on line 714

    Posted 2 years ago #
  2. sbillard

    Contributor
    Joined: May '07
    Posts: 10,427

    Could you please check and see what that line reads in your copy of lib-auth.php? The copy I have reads $candidate = array_unique($candidate); so I see no way it could generate the error you show.

    Posted 2 years ago #
  3. elrol

    Member
    Joined: Jan '09
    Posts: 46

    sbillard - my reads the same as yours

    $candidate = array_unique($candidate);

    I have never seen an error like this before.

    let me try clearing my cache and restarting my browser again. Should I try session management rather than cookie based?

    Posted 2 years ago #
  4. elrol

    Member
    Joined: Jan '09
    Posts: 46

    When I was trying the admin in internet explorer, the logout works properly. But it still does not work in Firefox

    Posted 2 years ago #
  5. sbillard

    Contributor
    Joined: May '07
    Posts: 10,427

    Does the error happen only with Firefox? That would really be strange since the code is server side. But maybe there is a problem with Firefox cookies.

    Posted 2 years ago #
  6. elrol

    Member
    Joined: Jan '09
    Posts: 46

    I think there is an issue with Firefox cookies here. It works properly now that I have cleared cache

    Thanks

    Posted 2 years ago #
  7. sbillard

    Contributor
    Joined: May '07
    Posts: 10,427

    Ok, keep us posted if the problem comes back.

    Posted 2 years ago #

RSS feed for this topic

Reply

You must log in to post.