zenphoto forums » Usage Support

SITEMAPS and RSS

(8 posts)
  • Started 5 months ago by mondeduvelo
  • Latest reply from acrylian

No tags yet.

  1. mondeduvelo

    Member
    Joined: Sep '16
    Posts: 15

    Good evening,

    I just opened my site via zenphoto;) if you want to look it's here : http://www.lesmaillotsdevelo.com/

    I am wondering how to automatically generate sitemaps and rss feeds without going through the button that is on the home page of the admin

    Posted 5 months ago #
  2. Zenphoto development team
    acrylian

    Zenphoto team
    Joined: Jul '07
    Posts: 16,749

    RSS is generated automatically. The buttons are just for manually clearing the cached ones in case you don't want to wait until it updates itself. You can of course just disable the rss cache.

    Sitemaps currently cannot be generated automatically.

    Don't forget to read the Forum rules and usage resources
    Posted 5 months ago #
  3. mondeduvelo

    Member
    Joined: Sep '16
    Posts: 15

    ok thanks

    Posted 5 months ago #
  4. MarkRH

    Senior
    Joined: Jun '14
    Posts: 90

    Uhm, what button are you referring to concerning the RSS cache? I don't notice one. Only thing I know of is the RSS plugin option to turn on/off the cache.

    Posted 5 months ago #
  5. mondeduvelo

    Member
    Joined: Sep '16
    Posts: 15

    i'm a problem with google sitemaps http://www.lesmaillotsdevelo.com/cache_html/sitemap/sitemap-zenphoto-images-101.xml

    # Type Problème Description Nombre de problèmes Exemple Ligne Détectée
    1

    Erreurs
    Balise XML manquante
    Cette balise obligatoire est introuvable. Ajoutez-la et réessayez.
    1
    Balise parent : urlset
    Tag : url

    what's happened ?

    Posted 5 months ago #
  6. Zenphoto development team
    acrylian

    Zenphoto team
    Joined: Jul '07
    Posts: 16,749

    @MarkRH: You need to enable the cacheManager plugin to get button to clear all caches manually.

    @mondeduvelo: In the future please switch Zenphoto to the native English to post error messages (or at least translate them beforehand). We sadly don't speak French and it saves us time to help. Thanks.

    It seems the sitemaps generated misses a doctype define like <?xml version="1.0" encoding="UTF-8"?> at the beginning. We will look into that. However according to sitemap validators it is considered just a warning and nevertheless considered valid XML. Therefore it should work.

    Don't forget to read the Forum rules and usage resources
    Posted 5 months ago #
  7. MarkRH

    Senior
    Joined: Jun '14
    Posts: 90

    @acrylian: Ah, thanks.

    Posted 5 months ago #
  8. Zenphoto development team
    acrylian

    Zenphoto team
    Joined: Jul '07
    Posts: 16,749

    I looked at the sitemaps plugin and it follows completely the specifications and does include <?xml version="1.0" encoding="UTF-8"?> (which does not show if you view it on the sitemap page). Sitemaps don't require any doctype besides that as html documents do.

    Don't forget to read the Forum rules and usage resources
    Posted 5 months ago #

RSS feed for this topic

Reply

You must log in to post.