zenphoto forums » Plugins

where is auto_backup store the backup files?

(7 posts)
  • Started 2 months ago by fneumeier
  • Latest reply from fneumeier

Tags:

  1. fneumeier

    Junior
    Joined: Mar '15
    Posts: 6

    Hi,

    does anyone know where the auto_backup plugin is supposed to store the actual backup files?

    I can't find any documentation about this, neither can I find any backup files on my webserver.

    I'm running Zenphoto on PHP7, if that matters.

    Thanks and kind regards,
    Franz

    Posted 2 months ago #
  2. Zenphoto development team
    acrylian

    Zenphoto team
    Joined: Jul '07
    Posts: 16,850

    It stores the backups right in the /backups folder in the root of your install. The folder is or should be created by the plugin. If not review your PHP error logs for file/folder permission issues.

    Don't forget to read the Forum rules and usage resources
    Posted 2 months ago #
  3. fneumeier

    Junior
    Joined: Mar '15
    Posts: 6

    Okay, thanks. Checked and there are no PHP errors in the error logs.

    When I do a manual backup from the Zenphoto backend, it works and the backup file appears in the /backup/ folder.

    But at the same time, auto_backup does not work. And there is no error message when changing the plugin's settings as well.

    Posted 2 months ago #
  4. Zenphoto development team
    fretzl

    Zenphoto team
    Joined: Sep '08
    Posts: 1,115

    Maybe the plugin info helps:

    The website must be visited and live pages must be served for this plugin to be able to check if it is time to run.

    Inacative or heavily cached sites may not get backed up as frequently as the interval specifies. Of course, if there is no dynamic activity on the site, there probably is little need to do the backup in the first place.

    Don't forget to read the Forum rules and usage resources
    Posted 2 months ago #
  5. fneumeier

    Junior
    Joined: Mar '15
    Posts: 6

    Unfortunately that doesn't help as there is lots of traffic on the website and cache is not an issue either. Of course I've been checking the plugin info before posting here ;-)

    Is there probably a way to trigger the regular backup function via a cron job so I don't have to rely on the auto_backup plugin?

    Posted 2 months ago #
  6. sbillard

    Contributor
    Joined: May '07
    Posts: 10,520

    Does your security log show any "cron_runner" entries? Autobackup uses the zenphoto cron facility to launch the backup script.

    Alos look in your database for the option "last_backup_run" and see what that says.

    Autobackup attaches to the theme_head and admin_head filters. It is certainly possible that a specific theme has not applied the theme_headfilter, but then lots of things would not work. Certainly all the standard themes do apply it. The admin_head cannot be avoided. So at least visiting your administrative pages should invoke autobackup.

    Posted 2 months ago #
  7. fneumeier

    Junior
    Joined: Mar '15
    Posts: 6

    Okay, thanks. I'll check into that. I have derivated my own theme from one of the standard themes, so maybe I removed important something by accident. THanks for guiding me in the (hopefully) right direction!

    Posted 2 months ago #

RSS feed for this topic

Reply

You must log in to post.