zenphoto forums » General Zenphoto Discussion

Problem with 'Date' field

(2 posts)

Tags:

  1. redstick

    Apprentice
    Joined: Jul '17
    Posts: 4

    I know that if there is no information in 'Metadata' the date field is filled with the current date & time. However, if I have a photo where I only know the year it was taken and enter JUST the year eg. 1982 the date is saved as 1982-07-10. The field will add the CURRENT month and day.
    Is it possible to stop the date field from doing this?

    If I enter just Year and Month eg. 1982-07 then the date is saved with the day set at 01. (1982-07-01)
    If i enter the date as 1982-07-00 the date is saved as 1982-06-30. These last points are not of major concern because if I know the year and month then entering an arbitrary day eg. 1982-07-01 will retain the year and month.

    Posted 1 week ago #
  2. Zenphoto development team
    acrylian

    Zenphoto team
    Joined: Jul '07
    Posts: 16,800

    The database field (if you are referring to that) requires a valid date format. And that format is simply y-m-d so any missing part is added to be valid.

    1982-07-00 in any case is not a valid date so no wonder it takes the next correct date instead.

    There is no way around this, you have to enter either a valid date or leave it blank so the current date is used as you noticed.

    Don't forget to read the Forum rules and usage resources
    Posted 1 week ago #

RSS feed for this topic

Reply

You must log in to post.